Pager problems?

Sasha_Vasko@osca.state.mo.us
Mon, 24 Aug 1998 15:08:13 -0500



>I have been using 1.4.5 for a while now, and I have just noticed a problem
with
>my Pager. Here is my config:
>
>#------------------------------------------------------------------------
># Pager
>#
>DeskTopScale         32
>DeskTopSize          2x2
>
>*PagerBack           #908090
>*PagerFore           #484048
>*PagerFont           adobe-helvetica-bold-o-*-*-10-*-*-*-*-*-*-*
>*PagerHilight        #cab3ca
>*PagerGeometry       -1-1
>*PagerRedrawBg       0
>*PagerAlign          0
>*PagerLabel          0 Desktop
>*PagerSmallFont      5x18
>
>I have it SwallowModule in the Wharf, and I get a nice 2x2 screen. The
problem
>is I really have a 3x3 virtual desktop, the other 5 are just always
hidden,
>but I can access them though a keyboard shortcut and if I click and drag
on
>the very edge of the virtual desktop. This problem also happens if I just
>run the Pager as a module without swallowing it. Is my config wrong? I
have
>been looking at the Pager source, but my limited knowledge of the X
protocol
>has not allowed me to pinpoint what the problem is at this time. Does
anyone
>else have this problem? I have linux 2.0.35, XFree 3.3.2, and Afterstep
1.4.5
>that I got from ftp.afterstep.org, I run Slackware 3.5.

Check that you have  the following set up :

*PagerRows            3
*PagerColumns        3

This is actualy setting Pager's number of Desk windows and its positions.
DeskTopSize       is only specifying the number of pages (screens) on each
Desk.

I presume that you already have

Module  "I"     Pager 0 5

in autoexec, or

*Wharf Pager - SwallowModule "Pager" Pager 0 5

in wharf to start your pager.


>David
Sasha



--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.caldera.com/linuxcenter/forums/afterstep.html