FocusFollows Mouse in 1.5pre9

Doug Alcorn (alcornd@earthlink.net)
28 Aug 1998 12:11:46 -0400


I have noticed something mildly annoying since upgrading to 1.5pre9.
It appears that when I use the key mapping setup for Scroll +/-100
+/-100 that sometimes the window on the new screen does not recieve
focus even though the mouse is over that window.

I don't know if this is a problem in the afterstep or just in my
feels file.  I am not sure what other information to give.  Oh yea, it
doesn't happen every time.  Actually, I think only one application
causes it to happen.  I have Lotus Notes for UNIX (a notorious poorly
behaved application) running as a remote process displaying back to my
host.  When LN gets the focus, it doesn't give it up when I switch
screens.  Is this a afterstep function or an application
function?

While I am at it, LN also has another quasi-afterstep quirk.
When the window is first drawn, it gets the correct window title.  As
soon as the new window gets focus, the widow title blanks out.  It
remains blank until I restart the afterstep.  Then as soon as the
window gets focus again, I loose the window title.

Any guesses?  Any things you want me to try?  If you are specific, I
can do some debugging to get a stack trace or something.

-- 
 (__)  Doug Alcorn                 
 oo )  (Fledgling XEmacs User)
 |_/\  alcornd@earthlink.net       

--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.caldera.com/linuxcenter/forums/afterstep.html