Re: Re(2): Stupid problem

Andrew Sullivan (asullivan@sprint.ca)
Fri, 25 Sep 1998 13:15:14 -0400 (EDT)


On Thu, 24 Sep 1998, Ron Thompson wrote:

> Okay, I tried a simple .Xclients also, and it just wouldn't start up at
> all, since it couldn't successfully exec afterstep.  I even tried it with
> the full path.  8-(
> I'm really upset about this!  I >cannot< get afterstep 1.5Beta4 to run
> from xdm.  Can't SOMEONE figure this out?  Is there something I'm missing?
>  The older aftersteps had no problem running from xdm!

Is the new binary of afterstep in your system's path?  (I don't use RH,
and the few times I used xdm it started from .xsession, so I don't know if
this is the real problem; but it's a suggestion.)

The old binaries of AS used to be in /usr/X11R6/bin.  The new binaries are
not there -- I have mine in /usr/local/bin, but not everyone does.  In any
case, you obviously know where you installed this.

Now, if the new path to the binaries is not specified, you may run into
problems (even if you specify the full path initially, I expect, because
the modules won't load.  Is this true?  Anyone?).  So, you can specify the
path to the binaries (and to the config files, too?  Is that necessary?)
in (well, I have it in my .xsession file -- I don't know anything about
how .Xclients works) the relevant file.  In my .xsession, for instance, is

	export PATH=$PATH:/usr/local/bin
	exec afterstep
 
(I haven't used this with the new binaries, so I don't know if it works.)

I'm sorrt, I haven't been following this thread very carefully, so if
you've already tried this, or it's been suggested, I'm sorry.

A

Andrew Sullivan | asullivan@sprint.ca (better)| ajsulliv@mcmaster.ca (worse)
                                   *  *  *
'finger -l ajsulliv@mcmail.cis.mcmaster.ca' to find the AfterStep FAQ file.


--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.caldera.com/linuxcenter/forums/afterstep.html