Re: Icon behavior & background pixmaps.

Ethan (allanon@crystaltokyo.com)
Sun, 1 Nov 1998 08:26:25 -0800 (PST)



On Sun, 1 Nov 1998, P.J. Bolle wrote:

> 	My first difficulty I posted a while back, but got no response
> on it, so I'm giving it a second try. I have an IconBox defined, yet
> when I iconify anything, it appears iconified in the location of its'
> original window's upper-right corner. What did I miss?

This could happen if you specified an invalid IconBox, or the icon is 
unable to fit in any valid IconBox for some reason (such as 
StubbornIconPlacement and a window that takes up the entire screen).

> 	Secondly, I have created the 'backgrounds' directory in my
> ~/G/L/A/ path, and updated my start menu. All the xpm pics are present
> in the menu now, but no matter which I select, I end up with the
> Wharf's background, tiled all across the desktop. I even removed the
> dir, so that the menu defaulted back to
> /usr/local/share/afterstep/backgrounds/, but even these produced the
> same effect. Could someone please point out my oversights?

Maybe a permissions problem?  If not, try moving your GNUstep to a backup 
and re-installing AS.

> 	Lastly, my thanks to Ethan Fischer for the 'ascp' assistance.
> Only difficulties I have now are that I can only alter existing Wharf
> entries (can't add any), and the 'autoexec' portion does nothing
> ("Action" and "ID" are both listed, but the actual functions are not;
> nor can I change these). Also, I'm not sure if this is a known bug or
> not, but the Pixmap Browser keeps coming up empty as well.

You're welcome. :)

ascp is alpha software - it's not fully implemented, and is buggy too.  
It's getting better, but it ain't perfect, yet.

----
Ethan Fischer
allanon@crystaltokyo.com
http://members.xoom.com/allanon1


--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.caldera.com/linuxcenter/forums/afterstep.html