Re: 1.5 dosent find X11 [was Re: IconBox placement.]

Andrew Sullivan (asullivan@sprint.ca)
Mon, 9 Nov 1998 13:29:37 -0500 (EST)


On 9 Nov 1998, Doug Alcorn wrote:

> This is a common problem.  Many folks don't have the devel versions of 
> the libraries installed.  It is also not a thing that is easy to
> explain to someone new to Linux/Unix.  Andrew, could we put a line in
> the FAQ about needing the includes that come in the devel packages?

Actually, it's already there.  The problem is usually that people don't
bother to read the FAQ:

> 2.5 Why do I keep getting compile errors?

> The most common reason for problems compiling is that you do not have
> all the necessary libraries and headers available on your system. This
> often happens to people who have recently upgraded their distribution
> of XFree86. The necessary libraries are included in an "optional" file
> which matches the version of XFree86 in question; the most recent of
> these is X332prog.tgz (for XFree86 3.3.2). You should be able to find
> the file you need wherever you obtained your distribution of X.

If someone has suggestions on making this clearer, however, I'd be happy
to hear them.

A.

Andrew Sullivan | asullivan@sprint.ca (better)| ajsulliv@mcmaster.ca (worse)
                                   *  *  *
                Go to http://lowrent.org/asfaq/, or issue
'finger -l ajsulliv@mcmail.cis.mcmaster.ca' to find the AfterStep FAQ file.


--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.caldera.com/linuxcenter/forums/afterstep.html