RE: Problems with cygwin-32-1.4.4

Isaque Galdino (isaque@uol.com.br)
Mon, 4 Jan 1999 18:50:34 -0300


Humm, maybe this is the problem, I'm using the cygwin b20 version instead of b19.
I've tried to compile the version 1.6.6 and it's giving the same error too.

I'm going to make others tests. Anyway, thank you all !

isaque@uol.com.br

-----Original Message-----
From:	J.D. Jordan [SMTP:jdj5e@virginia.edu]
Sent:	Monday, January 04, 1999 3:20 PM
To:	'afterstep@linuxcenter.com'
Subject:	RE: Problems with cygwin-32-1.4.4

He's trying to run an AS binary that was compiled under cygnus in Windows.
You might make sure that you are using the corect version of cygnus for
that binary, also make sure you have the corect X11 version for that
binary, and if you grab the X11 binaries, grab the ones compatible with
your version of cygnus.  Also you have to be running an X Server on your
machine for that version of AS to work, and make sure you have DISPLAY set
to localhost, or your machine's dns or ip.  Other then that, AS wasn't
meant to work under cygnus, so if you can get it to work, woo hoo! =), you
might try grabbing the latest sources and compiling it yourself, I have no
clue how succesfull you will be in that venture though, I expect you'd
probably have to hack at the sources alittle to get it to work.

JD


On Mon, 4 Jan 1999, Andrew Sullivan wrote:

> On Mon, 4 Jan 1999, Isaque Galdino wrote:
> 
> > Ok, I did, (Thank you!) but now there is another error:
> > /personal/v_araujig>afterstep
> >  melting  melting Colordepth : 32
> > AfterStep: can't get font -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
> > AfterStep: can't get font -adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
> > AfterStep: can't get font -*-times-medium-*-*-*-*-120-*-*-*-*-*-*
> > [main] C:\usr\X11R6.3\bin\afterstep.exe 1218 (0) handle_exceptions:
> > Exception: STATUS_ACCESS_VIOLATION [main] afterstep 1218 (0)
> > handle_exceptions: Dumping stack trace to afterstep.exe.core
> 
> I'm not sure exactly what's going on here, but there is at least one, and
> possibly a second, problem I can see.
> 
> The first is that AS is looking for some fonts that you apparently either
> don't have on your system, or else do not have access to.
> 
> The second, possible problem is that you're trying to call afterstep
> directly.  That won't work.  You need to call if from xinit (use your
> .xinitrc file: read the docs about this).
> 
> >From the version number, I'm assuming you're using 1.4.4.  I _strongly_
> advise you to upgrade, as there were several nasty bugs in 1.4.4.  Also,
> if you upgraded from 1.4, nothing will work.  You'll need to remove your
> old ~/GNUstep/Library/AfterStep directory.  There is a protracted
> discussion of this in the FAQ.
> 
> A
> 
> Andrew Sullivan | asullivan@sprint.ca (better)| ajsulliv@mcmaster.ca (worse)
>                                    *  *  *
>               Go to http://www.afterstep.org/help/, or issue
> 'finger -l ajsulliv@mcmail.cis.mcmaster.ca' to find the AfterStep FAQ file.


--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.caldera.com/linuxcenter/forums/afterstep.html