Re: ASFiles 1.0

David Mihm (davemann@ionet.net)
Tue, 9 Feb 1999 22:54:56 -0600 (CST)


On Tue, 9 Feb 1999, Newell, Chris wrote:

! Just downloaded ASFiles 1.0.  All compiled well.  The trouble I am having is
! with file association.  If I double-click on a data file the associated
! application starts but does not load the data file.  It appears that arg1,
! or $1, is not passed to the associated application.  I don't have this
! problem with xfm, which leads me to believe that it is a configuration issue
! with ASFiles.  I am using the supplied .Filesrc file with no modifications.
! As an example, the line in my rc file looks like this:
! 
!   *.jpg::exec xv $1:
! 
! Double-clicking on any JPEG file will start xv but not load the JPEG file.

	I have this same line in my own ~/.Filesrc, with  the exception of
using an xpm (*.jpg:file-dot-jpg.xpm:exec xv $1:), and it appears to
function properly.  There are a few things I might suggest:  does the file
have the correct permissions, is it being edited in dos, is the jpg file a
".jpeg" or ".JPG"?  Since the image file isn't done with the magic
headers, the extension must be what it's defined as - case counts.  If all
these are correct, then my guess would be that the compile had some
non-fatal errors or something which was required was not found during
./configure.

	Sorry I can't be of more help.

+--------------------------------------------------------------------+
| d a v i d  @  m i h m                         reality.sys corrupt! |
| davemann-at-ionet-dot-net                    reboot universe(y,n)? |
| [www|ftp].the-site.loonybin.net                         ICQ:906859 |
| webmaster-at-afterstep-dot-org      ftpmaster-at-afterstep-dot-org |
+--------------------------------------------------------------------+
  Key fingerprint  = E4 90 15 ED E5 9F 18 8A B0 CC FF 68 61 36 4A 6F


--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.caldera.com/linuxcenter/forums/afterstep.html