Re: libjpeg problesm.

Doug Alcorn (alcornd@earthlink.net)
28 Mar 1999 13:19:06 -0500


Tyson La Tourrette <tower@oit.pdx.edu> writes:

> I am trying to compile 1.6.10 or 1.7.74 onto solaris. No matter what I do
> i can not get the configure script to recognize my libjpeg libraries. I
> downloaded and installed the ones mentioned on the AS webpage (ver 6.2). I
> run configure with the "--with-jpeg-library=/u/tcl/usr/lib" arguement
> (that is the dir my libjpeg.so and libjpeg.a files are) and i still get
> the error "afterstep requires libjpeg version 6.0 or later" and jpeg
> support is disabled. The lib dir is in my lib path. Any idea what could be
> wrong?
> 
I am going to try and take a stab at this.  First, are you root on
this solaris box?  If yes, you need to be sure that you run 'ldconfig' 
after you install the libjpeg.  This will add the jpeg libraries into
the list of those available for linking.  If you are not root, I am
guessing that you will need to set an environment variable (probably
something like LD_LIBRARY_PATH) to tell the linker where to find the
jpeg libraries.  

On another note, I am not sure what the --with-jpeg-library really
does.  I don't know if it is expecting the directory of libjepg or the 
actual library (ie, /u/tcl/usr/lib/libjpeg...).

> Also on a similar but different note. I keep getting a linker error of
> function snprintf not defined in module gnome.o when trying to compile
> 1.7.74. Any idea why? Do I have to have gnome installed onto my system for
> the new AS?
> 

I have heard rumors of workings between AS and Gnome.  I am betting
there are some dependencies in the new devel tree.  I am also betting
that there is a configure switch (like --without-gnome) that would
compile AS without gnome linkages.

-- 
 (__)  Doug Alcorn
 oo /  alcornd@earthlink.net
 |_/   

--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.caldera.com/linuxcenter/forums/afterstep.html