libXpm problem - loading image

Derick Wong (derickwong@hotmail.com)
Wed, 21 Apr 1999 08:04:14 MYT


Hi,

I'd actually sent this mail before. But just in case any of you had
experience this before, perhaps you would like to share your
experience.

I've compiled the afterstep 1.6.10 with libXpm version 3 preinstalled
on my machine. However, I'd downloaded xpm-3.4k (libXpm 4.11) and
tried to use the library libXpm.a and libXpm.so.4.11 (compiled them
myself) in my afterstep. When I start the afterstep, it always says

	LoadImage: cannot load XPM file
[$HOME/GNUstep/Library/AfterStep/desktop/icons/8bpp/__.xpm]
	LoadImage: you need to install libXPM v 4.0 or higher, in 
order to read images of this format.

It managed to run but without the necessary graphics displayed. It's
just a barebone afterstep and the xterm window does not have the
minimize, maximize and destroy button on the titlebar.

BTW, I'm using the 8bpp as my machine can only support that level of
graphics.

This is how I configured my afterstep:

./configure --prefix=$HOME/coolstuff/afterstep
--x-includes=/usr/X11R6/include/X11 --x-libraries=/usr/X11R6/lib
--enable-texture --with-x --with-xpm-includes=$HOME/xpm-3.4k/lib
--with-xpm-library=$HOME/xpm-3.4k/lib --with-xpm --disable-script
--with-png=no --with-jpeg=no


______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com

--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.caldera.com/linuxcenter/forums/afterstep.html