Re: AS 1.7.104 crashing

Rafal Wierzbicki (rafal@mcss.cas.mcmaster.ca)
Tue, 25 May 1999 16:21:58 -0400 (EDT)



This means your X server crashed, not afterstep, you can send a bug report
to the XFree86 team.

On Mon, 24 May 1999, Martin DiViaio wrote:

> Hello,
> 
> I don't know if this was recently posted to the list or not. I had to do
> a complete re-install of my system yesturday and lost some files in the
> process.
> 
> I'm running AS 1.7.104 (compiled with the --enable-different-looknfeels
> option) and when ever I attempt to use "update all" from the start menu,
> the xserver crashes.
> 
> OS: RedHat 5.2, Kernel 2.0.36. wmconfig is disabled.
> 
> No other programs were running (besides my background daemons.)
> 
> The complete output from the console when the server was running is
> below.
> 
> A .AfterStep-errors file was not generated.
> 
> There also wasn't a core dump.
> 
> There was nothing logged through syslogd.
> 
> (If there is anything else you need, please let me know.)
> 
> I was playing around with my ~/G/L/A/feels directory when the crash
> first happened. I completely deleted the directory and restarted. When I
> attempted to update all it crashed again. I then completely deleted the
> GNUstep tree. Again, AS crashes when I attempt to update all.
> 
> The only other thing I have done is added a large number of jpeg files
> to the /usr/local/share/afterstep/backgrounds directory.
> 
> XFree86 Version 3.3.2.3 / X Window System
> (protocol Version 11, revision 0, vendor release 6300)
> Release Date: July 15 1998
> 	If the server is older than 6-12 months, or if your card is newer
> 	than the above date, look for a newer version before reporting
> 	problems.  (see http://www.XFree86.Org/FAQ)
> Operating System: Linux 2.0.34 i686 [ELF] 
> Configured drivers:
>   SVGA: server for SVGA graphics adaptors (Patchlevel 0):
> (using VT number 7)
> 
> XF86Config: /usr/X11R6/lib/X11/XF86Config
> (**) stands for supplied, (--) stands for probed/default values
> (**) XKB: keycodes: "xfree86"
> (**) XKB: types: "default"
> (**) XKB: compat: "default"
> (**) XKB: symbols: "us(pc101)"
> (**) XKB: geometry: "pc"
> (**) XKB: rules: "xfree86"
> (**) XKB: model: "pc101"
> (**) XKB: layout: "us"
> (**) Mouse: type: PS/2, device: /dev/mouse, buttons: 3
> (**) Mouse: 3 button emulation (timeout: 50ms)
> (**) SVGA: Graphics device ID: "My Video Card"
> (**) SVGA: Monitor ID: "My Monitor"
> (--) SVGA: Mode "800x600" needs hsync freq of 35.16 kHz. Deleted.
> (--) SVGA: Mode "640x480" needs hsync freq of 36.46 kHz. Deleted.
> (--) SVGA: Mode "800x600" needs hsync freq of 37.88 kHz. Deleted.
> (--) SVGA: Mode "800x600" needs hsync freq of 48.08 kHz. Deleted.
> (--) SVGA: Mode "1024x768" needs hsync freq of 48.36 kHz. Deleted.
> (--) SVGA: Mode "1024x768" needs hsync freq of 56.48 kHz. Deleted.
> (--) SVGA: Mode "1024x768" needs hsync freq of 62.50 kHz. Deleted.
> (--) SVGA: Mode "1280x1024" needs hsync freq of 64.25 kHz. Deleted.
> (--) SVGA: Mode "1280x1024" needs hsync freq of 78.86 kHz. Deleted.
> (--) SVGA: Mode "1280x1024" needs hsync freq of 81.13 kHz. Deleted.
> (--) SVGA: Mode "320x240" needs hsync freq of 39.38 kHz. Deleted.
> (--) SVGA: Invalid vertical timing for mode "400x300". Deleted.
> (--) SVGA: Mode "400x300" needs hsync freq of 37.88 kHz. Deleted.
> (--) SVGA: Mode "400x300" needs hsync freq of 48.08 kHz. Deleted.
> (--) SVGA: Mode "480x300" needs hsync freq of 35.16 kHz. Deleted.
> (--) SVGA: Mode "480x300" needs hsync freq of 37.80 kHz. Deleted.
> (--) SVGA: Mode "480x300" needs hsync freq of 39.56 kHz. Deleted.
> (--) SVGA: Mode "480x300" needs hsync freq of 48.00 kHz. Deleted.
> (**) FontPath set to
> "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
> (--) SVGA: CHIPS: chip revision: 2
> (--) SVGA: Chipset: ct65545 
> (--) SVGA: CHIPS: no monitor detected.
> (--) SVGA: CHIPS: 1024 kB VRAM
> (--) SVGA: CHIPS: TFT probed.
> (--) SVGA: CHIPS: LCD
> (--) SVGA: CHIPS: Display Size: x=640; y=480
> (--) SVGA: CHIPS: VL Bus
> (--) SVGA: CHIPS: base address is set at 0x3000000.
> (--) SVGA: CHIPS: Linear addressing is enabled at 0x3000000.
> (**) SVGA: CHIPS: 16 bpp.
> (--) SVGA: CHIPS: Internal DAC disabled.
> (--) SVGA: CHIPS: syncronous reset ignored.
> (--) SVGA: CHIPS: using programmable clocks.
> (--) SVGA: chipset:  ct65545
> (--) SVGA: videoram: 1024k
> (--) SVGA: Effective pixel clocks available:
> 
> (**) SVGA: Using 16 bpp, Depth 16, Color weight: 565
> (--) SVGA: Maximum allowed dot-clock: 34.000 MHz
> (**) SVGA: Mode "640x480": mode clock =  25.175
> (**) SVGA: Virtual resolution set to 640x480
> (--) SVGA: SpeedUp code selection modified because virtualX != 1024
> (--) SVGA: CHIPS: 434176 bytes off-screen memory available
> (--) SVGA: CHIPS: H/W cursor selected
> (--) SVGA: CHIPS: SpeedUps selected (Flags=0xF)
> (--) SVGA: Using XAA (XFree86 Acceleration Architecture)
> (--) SVGA: XAA: Solid filled rectangles
> (--) SVGA: XAA: Screen-to-screen copy
> (--) SVGA: XAA: 8x8 pattern fill
> (--) SVGA: XAA: 8x8 color expand pattern fill
> (--) SVGA: XAA: CPU to screen color expansion (bitmap, TE/NonTE
> imagetext, TE/NonTE polytext)
> (--) SVGA: XAA: Using 5 128x128 areas for pixmap caching
> (--) SVGA: XAA: Caching tiles and stipples
> (--) SVGA: XAA: Horizontal and vertical lines and segments
> Detected colordepth : 16
> accepted module connection
> accepted module connection
> Wharf:invalid option BalloonFore	Black
> Wharf:invalid option BalloonBack	Grey70
> Wharf:invalid option BalloonFont
> -adobe-helvetica-bold-o-*-*-12-*-*-*-*-*-*-*
> accepted module connection
> accepted module connection
> Premature end of JPEG file
> Detected colordepth : 16
> Detected colordepth : 16
> 
> Fatal server error:
> Caught signal 11.  Server aborting
> 
> 
> When reporting a problem related to a server crash, please send
> the full server output, not just the last messages
> 
> X connection to :0.0 broken (explicit kill or server shutdown).
> X connection to :0.0 broken (explicit kill or server shutdown).
> xinit:  connection to X server lost.
> X connection to :0.0 broken (explicit kill or server shutdown).
> 
> --
>    WWW:   http://www.afterstep.org/
>    FTP:   ftp://ftp.afterstep.org/
>    MAIL:  http://www.calderasystems.com/linuxcenter/forums/afterstep.html
> 


--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.calderasystems.com/linuxcenter/forums/afterstep.html