Re: libjpeg.so.62 ??? UPDATE

Albert Dorofeev (albert@mail.dma.be)
Mon, 7 Jun 1999 13:30:59 +0200


On Mon, Jun 07, 1999 at 12:52:15AM +0100, John Archbold wrote:
> OK i ran ./configure --enable-shared --enable-static
> 
> then ran the following
> 
> make
> make install
> make install-lib
> 
> THIS INSTALLED the lib in /usr/local/lib, I also checked /etc/ld.so.conf to
> make sure it is reading that dir and it is. It is now being seen by ldconfig
> but AfterStep STILL says that libjpeg.so.62 isn't there. I ran rpm -i
> after......... and it said failed dependancies libjpeg.so.62 when it surely is
> there i am at a total loss here and i really want to install it.

Am I right in supposing that all those failure messages
about missing lib were given by the RPM and not by the
AfterStep itself? You did not succeed in installing AS
so you never could run it actually, right?
I am not familiar with the way RPM operates but I would
think that 
	- either it is checking for /usr/lib/<lib> and then
	you would have to put a symlink there pointing back
	to /usr/local/lib/<lib>
	- or it keeps its own database of what has been 
	installed so you'd have to either get an RPM of
	the library or 'force' the installation despite
	the failed dependencies (if that can be done)
In any case, just try to force it to install and then
see if running AS actually produces any errors.

-- 
Albert Dorofeev http://www.tigr.net/ http://bewoner.dma.be/Albert/
PGP fingerprint = C9 49 D0 F3 41 FA 8C D8  E9 5C 6A D4 F1 6D 65 15
  Anything good in life is either illegal, immoral or fattening.

--
   WWW:   http://www.afterstep.org/
   FTP:   ftp://ftp.afterstep.org/
   MAIL:  http://www.calderasystems.com/linuxcenter/forums/afterstep.html