Re: Error Message on Solaris 2.6

Jim Collins (jim_collins@110.net)
Wed, 16 Feb 2000 23:11:21 -0500


Hi,

For Solaris 2.6, make sure you include the Math library, libm.
So, for gcc add "-lm" or "pow" function will not be found.

- Jim Collins

Keith Spainhour wrote:
> 
> Hi,
> 
> I'm trying to get afterstep 1.8.0 working on Solaris 2.6 on an
> ultra-sparc 5.  It compiled ok, (lots of warnings) and installed
> fine.  But when I run afterstep I get the following message:
> 
> ld.so.1: afterstep: fatal: relocation error: file afterstep:
>          symbol __register_frame_info: referenced symbol not found
> Killed
> 
> Can anybody help me out or point me where there is a Solaris
> binary already available?
> 
> Thanks,
> --
> Keith Spainhour
> Software Engineer            keiths@cisco.com
> Cisco Systems                http://www.cisco.com
> --------------------------------------------------------------------
> To unsubscribe from this mailing list, simply type the following at #
> echo "unsubscribe as-users <your_email>" | mail majordomo@afterstep.org
--------------------------------------------------------------------
To unsubscribe from this mailing list, simply type the following at #
echo "unsubscribe as-users <your_email>" | mail majordomo@afterstep.org