Re: Wharf borders not redrawing

=?ISO-8859-1?Q?Christer_Th=F6rn?= (di00thch@ing.hj.se)
Sun, 02 Feb 2003 11:26:41 +0100


Hi, me again.
I took a closer look at Wharf.c and came up with a solution to the 
problem. I made a diff from the 1.8.11-tarball and put a patch here: 
<http://hj.se/~di00thch/Wharf.c.patch>. (Place in the same directory as 
  the original Wharf.c, run 'patch < Wharf.c.patch', 'make', 'make 
install', restart Wharf).
Maybe there are other ways of fixing it, but this one was the most 
straightforward I came up with. Hope it can be of some help or use.

Thanks,
--
Christer Thörn
di00thch@ing.hj.se


M.-A. DARCHE wrote:
> Christer Thörn wrote:
> 
>> Hi.
>> I've used AfterStep for a few years and has everything working nicely 
>> except for the problem that was previoulsy reported here: 
>> <http://www.tigr.net/afterstep/mail/user/2001-04/5.html>
>> When covering the Wharf with a window (or Wharf balloon) the edges 
>> around the buttons aren't redrawn. The content of each button is 
>> redrawn properly, but the edges reappear only when clicking a button.
>> I looked through Wharf.c briefley checking for ExposeEvents handling 
>> etc., but couldn't find any obvious problems.
>> Anyone know what gives here?
> 
> 
> Thank you for reporting this, Christer.
> 
> I thought I was the only one interested in this redrawn bug :-)
> 
> Maybe now that the 2 of us are requesting help on this...
> 
> Cheers,
> 


_______________________________________________
The AfterStep Window Manager for X User's Mailing List
http://mail.afterstep.org/mailman/listinfo/as-users