Re: test driving AS 1.99

Geoff Burling (llywrch@agora.rdrop.com)
Thu, 10 Apr 2003 22:05:16 -0700 (PDT)


On Tue, 8 Apr 2003, Sean Dague wrote:

> Just pulled AS CVS, and am testing driving it arround a bit.  I noticed
> quite a number of the ugly green and orange artifacts on my WinList and
> Wharf.  Is there any set of standard docs about configuration changes for
> the modules going from 1.8.11 -> 1.99?
>
I was surprised to see the same thing when I built AS today. Not only that,
but starting Pager would give me all sorts of error messages & would blow
up until I removed the configuration file in ~/G/L/A. (After that I still
got a number of error messages, but Pager worked.)

This happened on an install of Linux from Scratch, with the 2.4.19 kernel,
Xfree86 4.2.0, freetype 2.1.3, jpeg-6b, libpng-1.2.5 on a Dell PE6600 with
4 processors & a Rage XL video card. I compiled & installed AS 2.0 beta over
a build of AS 1.8.11 that ran quite happily in this environment. I used
the CVS files which I downloaded last night.

> If not I'll just poke at the /usr/local/share/afterstep files over the next
> few days.

Not to bad mouth all of the hard work Sasha put into this version of AfterStep,
but I suspect that someone will have to write a HOWTO for migrating from
1.8.x to 2.0. If no one else, I'll do it.

BTW, should recompiling aterm, ascpu & astime be part of the steps in
migrating? I'm seeing a number of errors reported from these applets under
2.0.
>
> I like what I see so far.  Will continue to test out and look for any
> issues.
>
> Thanks again for the great software Sasha.
>
Ditto.

Geoff


_______________________________________________
The AfterStep Window Manager for X User's Mailing List
http://mail.afterstep.org/mailman/listinfo/as-users