Re: current cvs builds but crashes

Aidan Kehoe (kehoea@parhasard.net)
Fri, 13 Jun 2003 17:39:19 +0100



 Ar an 13ú lá de mí 6, scríobh Graydon :

 > On Fri, Jun 13, 2003 at 09:17:32AM -0500, Sasha Vasko scripsit:
 > > >However, when I go to start it, I get the various usual :
 > > >
 > > >/usr/bin/X11/afterstep: relocation error: 
 > > >/usr/X11R6/lib/libAfterStep.so.0: undefined symbol: flip_gradient
 > > 
 > > you may need to do
 > > 
 > > make clean
 > > 
 > > prior to building it.
 > 
 > I did a clean download of afterstep-stable from cvs just now, copied it
 > to a directory called AfterStep-1.99.0, and tarred it up with everything
 > but /CVS.
 > 
 > I'm using a spec file with
 > 
 > ./configure --prefix=/usr/X11R6 --datadir=/usr/share \
 >         --with-desktops=1 \
 >         --with-deskgeometry=2x3 \
 >         --disable-staticlibs
 > 
 > as the configure line.
 > 
 > Adding 'make clean' before 'make' in the spec file, I still get
 > 
 > /usr/bin/X11/afterstep: relocation error: /usr/X11R6/lib/libAfterStep.so.0: undefined symbol: flip_gradient
 > 
 > As the only output from AfterStep before X server shutdown.
 > 
 > Interestingly enough, if I try 'afterstep -v' I get the same error with
 > that build but *not* with the previous one, which politely tells me
 > 
 > 11:36 graydon % afterstep -v
 > AfterStep version 1.99.0

Does "ldd /usr/bin/X11/afterstep" mention libAfterstep.so? If not, that
library may have to be added to the linker command line that creates the
binary. 

-- 
Parhásárd; rex quondam Pokémonorum, rex futuram Pokémonorum. 
_______________________________________________
The AfterStep Window Manager for X User's Mailing List
http://mail.afterstep.org/mailman/listinfo/as-users