odd window focus problem

Chris McCraw (fool@cs.utexas.edu)
Tue, 14 Oct 2003 16:52:04 -0500



hi folks,

	i've observed a not-entirely-reproducible bug that is really annoying
and thought perhaps someone here has seen it too and might have something
reproducible that tickles it so that it could be tracked down.

	occasionally, one of my windows loses ability to take keyboard focus.
before today i thought it might be the app's (opera) fault, but it just
happened to an rxvt window.  i can still interact with the mouse in the
window, but i cannot give it focus (the titlebar doesn't change to the
"focused" color/font).  when this happens, i also cannot move or resize
the window in question.  if i choose move from the
leftclickondesktop->windows menu, it will show me the geometry and
coordinates of wherever i move the cursor, but the window stays put.
i can still interact with the title bar (ie to hit the X to close/destroy).

running afterstep 2.0.0beta2, debian, xinerama--though this happens on
when apps are started on and used on either screen.

opera (any of the 7.2x series, of which 7.21 was just released today
and has already exhibited it for me) typically tickles this bug, no
matter where or with what geometry i start it.  i have to start it
several times to get one that works, and once i've gotten one that works
for 30 seconds, it's generally fine for days.
however, opera nearly always displays it immediately or on the second
or third focus event anyhow, while the rxvt that it happened to had
been active for days before it happened there.  i am only changing focus
directly with the mouse (sloppyfocus), not with alt-tab or by changing
desktops.

thanks for your attention.  i'm really enjoying as2.0 overall, just
some niggling details getting in the way of my bliss.
_______________________________________________
The AfterStep Window Manager for X User's Mailing List
http://mail.afterstep.org/mailman/listinfo/as-users