Re: afterstep2 and openbsd3.4

Sasha Vasko (sasha@aftercode.net)
Tue, 18 Nov 2003 08:18:12 -0600




Bo Byrd wrote:
> Hello i have been using afterstep1.8.9 with openbsd and am trying to 
> check out the AfterStep-2.00.beta2 version.  the ./configure went with 
> no problems at all, but the make did have a LOT of warnings (usually the 
> warning was {/usr/include/malloc.h:4: warning: #warning "<malloc.h> is 
> obsolete, use <stdlib.h>"} but it did complete.  The make install went 

Could you please get version from CVS. It should have most compile 
warnings fixed, as well as some other things :

cvs -d :pserver:anonymous@cvs.aftercode.net:/home/cvsroot login
cvs -d :pserver:anonymous@cvs.aftercode.net:/home/cvsroot co 		 
afterstep-stable

> without a hitch.  Now whenever I startx i get the grey X background but 
> nothing else happens, usually afterstep would start up due to the .xinit 
> and ./xinitrc file but now nothing happens.  Is there something special 
> the BSD OSs are supposed to go?

That is strange. Try replacing your ~/.xinitrc with :

echo "afterstep -l ~/afterstep.log" > ~/.xinitrc

and then see if there is anything meaningfull in ~/afterstep.log

> 
> Thanks,
> Bo Byrd


Sasha

_______________________________________________
The AfterStep Window Manager for X User's Mailing List
http://mail.afterstep.org/mailman/listinfo/as-users