Re: [As-users] AfterStep 2.00.beta5 released - 2nd problem

Fabrice Ilponse (fabrice@avertec.com)
Thu, 19 Aug 2004 10:49:22 +0200


Hi,

    This time afterstep crashed. I decided to rebuild it with debug=yes 
on and sigsegv=no.
    Some applications crashed due to an already signaled kind of bug : 
the debug messages.
    For instance for the Pager:
       0x3e8e8 in add_astbar_label (tbar=0x4124665b, col=0 '\000', row=0 
'\000', flip=689576,
    align=690848, h_padding=0, v_padding=0, text=0x0, encoding=0) at 
decor.c:970
970     LOCAL_DEBUG_CALLER_OUT( "label \"%s\"", text );

    for the WinList:
    WinList:1092905101:decor.c:set_astbar_hilite:> called from [unknown] 
with args(172ba8,1,0x6)
WinList:1092905101:decor.c:add_astbar_label:> called from [unknown] with 
args(label "Segmentation Fault trapped in WinList.
Please collect all the listed information and submit a bug report to 
<as-bugs@afterstep.org>.
If core dump was generated by this fault, please examine it with gdb and 
attach results to your report.
 You can use the following sequence to do so :
   gdb -core core /usr/local/bin/afterstep
   gdb>backtrace
   gdb>info frame
   gdb>info all-registers
   gdb>disassemble

 ps: the debug options  did not seem to affect the build of the WinList 
or there was an error in the building. sure a 'make clean' i did not do ;)

    For the old Pager story: the 4x2 workspace. I said it worked a 
little to fast. In fact when i try to go to workspace x>2 the workspace 
blocks on x=2.

c u

_______________________________________________
As-users mailing list
As-users@afterstep.org
http://mail.afterstep.org/mailman/listinfo/as-users