Re: [As-users] upgrading

Nathan Mahon (as_ml@vaevictus.net)
Thu, 10 Mar 2005 16:11:14 -0500


Sasha just fixed that, and then I checked my email.

n8

John Gruenenfelder wrote:

>On Tue, Mar 08, 2005 at 11:22:30AM -0600, Sasha Vasko wrote:
>  
>
>>I don't see how that error occured.
>>
>>But I noticed one thing - you use some interesting compile flags - it 
>>looks like you are building with --enable-audit. Don't do that as it 
>>will slow AfterStep to a crawl, and is only needed when one is debuggin 
>>memory leaks. another thing you may want to drop is 
>>-fommit-frame-pointer, as AfterStep contains some self-diagnostic code 
>>that relies on proper frame pointer.
>>
>>Could you please recompile without those? and if it still fails - what 
>>other flags you gave to configure ?
>>
>>
>>BTW I fixed few warnings from your log. Thanks
>>    
>>
>
>Okay, I've tried compiling again.  The make process still fails at the same
>asapp.h error.  Also, the make process still tries to continue even after the
>error occured.
>
>However, I did realize that I have been using gcc-4, the default compiler for
>Debian's AMD64 port (gcc-3.4 branch).  The log for that build is attached.
>
>I reran configure, this time giving it CC=gcc-3.4.  The asapp.h error no
>longer occurs, but there is a different error in pager now.  That log is also
>attached.
>
>This is all done from CVS current as of 09-03-2005.  Local time was about
>21:00 (-0700 GMT).
>
>
>  
>
>------------------------------------------------------------------------
>
>_______________________________________________
>As-users mailing list
>As-users@afterstep.org
>http://mail.afterstep.org/mailman/listinfo/as-users
>  
>

_______________________________________________
As-users mailing list
As-users@afterstep.org
http://mail.afterstep.org/mailman/listinfo/as-users